http://www.gpydt.cn

您的位置:股票易点通 > 股票公式 > 大智慧公式 > 正文

【股票入门】【大智慧】MACD叠加KDJ指标公式

DRAWGBK(close>0,STRIP(RGB(25,25,112),RGB(47,79,79),0));
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1),LINETHICK2,COLORWHITE;
D:SMA(K,3,1),LINETHICK2,COLOR00DDDD;
J:3*K-2*D,LINETHICK2,COLOR800080;
DIFF:EMA(CLOSE,12)-EMA(CLOSE,26),linethick0,COLOR0099FF;
DEA :EMA(DIFF,9),linethick0,COLORD89837;
MACD:2*(DIFF-DEA),COLORFF9999,linethick0;
YLZC:=if(close=INDEXC,(INDEXC+INDEXh+INDEXl+INDEXO)/4,AMOUNT/(vol+0.01)/100);
阻价:=if(close=INDEXC,YLZC+INDEXC-INDEXl,YLZC+(close-low));
支价:=if(close=INDEXC,INDEXl+INDEXC-YLZC,low+(close-YLZC));
今压:REF(阻价,1),LINETHICK0,COLORAA11BB;
今撑:REF(支价,1),LINETHICK0,COLOR009900;
明压:阻价,LINETHICK0;
明撑:支价,LINETHICK0;
rsv1:=(hhv(h,9.8)-c)/(hhv(h,9.8)-llv(l,9.8))*101;
kk:=sma(rsv1,3,1);
dd:=sma(kk,3,1);
jj:=3*kk-2*dd;
买卖:=if(jj>=100,100,if(jj=ref(MACD,1) and MACD>0;
CDC:=MACD>ref(MACD,1) and MACDref(diff,1),80,80,2,1),COLORRED;
STICKLINE(K=(0-0.05) AND MACD0 AND MACD>=REF(MACD,1) AND DIFFREF(DIFF,A1+1) AND CROSS(DIFF,DEA);
DRAWTEXT(底背离,DEAA*0.99-16,’ 底背离’),Color0099FF;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)DIFF AND CROSS(DEA,DIFF);
DRAWTEXT(FILTER(顶背离,5),DEAA*1.02,’顶背离’),COLORDDAAAA;
{周金叉,死叉}
周DIFF:=”MACD.DIFF#WEEK”;
周DEA:=”MACD.DEA#WEEK”;
周MACD:=”MACD.MACD#WEEK”;
DIF周金叉:=CROSS(周DIFF,周DEA);
DRAWTEXT(DIF周金叉,DEAA,’DIFF周金叉’),COLOR0099FF;
DRAWTEXT(CROSS(周DEA,周DIFF),DEAA+4,’DIFF周死叉’),align0,COLORCDFFBB;
MACD周金叉:=CROSS(周MACD,周DIFF) AND 周MACD>=(0-0.05) AND 周MACD0,5),D+8,’顶背离’),COLORFFAA22;
MD1:=MA(CLOSE,80)-MA(CLOSE,13)/3;
MD2:=MA((CLOSE-MD1)/MD1,3);
买点1:=CROSS(MD2,0) AND LOW/REF(HIGH,1)=REF(MACD,5) AND open0 AND MACD=0,3) and Jref(J,1) and D>ref(D,1) and (diff>=ref(diff,1) or dea>=ref(dea,1)),1,0);
DRAWTEXT(佳点=1,macda*0.98,’佳点’),color0099FF;
DX0:=EMA(CLOSE,2)-EMA(OPEN,5);
DX1:=if(CROSS(DX0,MACD) AND LOWREF(VOL,1))>=0.7 AND (CLOSE0),5) AND JREF(MD2,1),3)=3 AND COUNT(MD2REF(CLOSE,1) AND JREF(J,1);
DRAWTEXT(买点1 or 买点2,D-1,’买’),colorff00CC;
{预涨}
YZ:=(INTPART(SMA(RSV,3,1))+INTPART(SMA(K,3,1)))/2;
预涨:=cross(yz,50) and jref(diff,1);
DRAWTEXT(预涨,d*0.6,’预n涨’),COLORA52A2A;
KD金叉:=cross(K,D)and J>20 and J

郑重声明:本文版权归原作者所有,转载文章仅为传播更多信息之目的,如作者信息标记有误,请第一时间联系我们修改或删除,多谢。

相关文章阅读