http://www.gpydt.cn

您的位置:股票易点通 > 股票公式 > 大智慧公式 > 正文

【股票知识大全】大智慧五彩K线,MACD多周期共振,分时背离指标

五彩K线:

 Var1:=AMOUNT/VOL;

A:=SMA(Var1,5,1)-SMA(Var1,55,1); 
B:=SMA((A-SMA(A,5,1)),5,1); 
{顶尖财经:股票学院 }
STICKLINE(CLOSE>MA(CLOSE,5) AND A>REF(A,1) AND B>REF(B,1),L,H,0.5,0),COLOR0000FF;
STICKLINE(CLOSE>MA(CLOSE,5) AND A>REF(A,1) AND B>REF(B,1),C,O,8,0),COLOR000000;
STICKLINE(CLOSE>MA(CLOSE,5) AND A>REF(A,1) AND B>REF(B,1),C,O,8,1),COLOR0000FF;
STICKLINE(CROSS(CLOSE,MA(CLOSE,5)) AND A>REF(A,1) AND B>REF(B,1),C,O,8,0),COLOR0000FF;
STICKLINE(CLOSE<MA(CLOSE,5) AND A>REF(A,1) AND B>REF(B,1),L,H,0.5,0),COLORFFFFFF;
STICKLINE(CLOSE<MA(CLOSE,5) AND A>REF(A,1) AND B>REF(B,1),C,O,8,0),COLOR000000;
STICKLINE(CLOSE<MA(CLOSE,5) AND A>REF(A,1) AND B>REF(B,1),C,O,8,1),COLORFFFFFF;
STICKLINE(A<REF(A,3) AND B<REF(B,3),L,H,0.5,0),COLOR00FF00;
STICKLINE(A<REF(A,3) AND B<REF(B,3),C,O,8,0),COLOR000000;
STICKLINE(A<REF(A,3) AND B<REF(B,3),C,O,8,1),COLOR00FF00;
STICKLINE(A>REF(A,1) AND B<REF(B,1),L,H,0.5,0),COLORFFFFFF;
STICKLINE(A>REF(A,1) AND B<REF(B,1),C,O,8,0),COLOR000000;
STICKLINE(A>REF(A,1) AND B<REF(B,1),C,O,8,1),COLORFFFFFF;
STICKLINE(A<REF(A,1) AND B>REF(B,1),L,H,0.5,0),COLORFFFFFF;
STICKLINE(A<REF(A,1) AND B>REF(B,1),C,O,8,0),COLOR000000;
STICKLINE(A<REF(A,1) AND B>REF(B,1),C,O,8,1),COLORFFFFFF;
DRAWTEXTABS(0,10,'一小股民'),COLOR333333;



MACD周月(MACD多周期共振):

月DIF:"MACD.DIfF#MONTH";

月DEA:"MACD.DEA#MONTH";
周DIF:"MACD.DIFf#WEEK";
周DEA:"MACD.DEA#WEEK";
FILLRGN(月DIF,月DEA,月DIF>月DEA,RGB(250,0,250),月DIF<月DEA,RGB(0,250,250));
FILLRGN(周DIF,周DEA,周DIF>周DEA,RGB(150,50,150),周DIF<周DEA,RGB(30,200,250));
 
MACD周金叉:CROSS(周DIF,周DEA)*0.3,COLORRED,LINETHICK2;
MACD月金叉:CROSS(月DIF,月DEA)*0.4,COLORYELLOW,LINETHICK2;
{DRAWTEXT(MACD周金叉=1,0.35,51),COLORRED;}
DIF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIF,9);
MACD:(DIF-DEA)*2,COLORSTICK;
VAR2:=EMA(DIF,9);
VAR3:=DIF>VAR2;
VAR4:=DIF<VAR2;
MACD:="MACD.MACD";
 
PARTLINE(MACD+0.06,CROSS(DIF,DEA) AND DIF<(-0.1),RGB(255,255,0)),cIRCLEDOT,LINETHICK4;
 
VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
OBV2:=EMA(OBV1,3)-MA(OBV1,9);
OBV3:=EMA(IF(OBV2>0,OBV2,0),3);
MAC3:=MA(C,3);
 
吸:=MACD<0 AND MACD>REF(MACD,1);
拉:=MACD>0 AND MACD>REF(MACD,1);
派:=MACD>0 AND MACD<REF(MACD,1);
落:=MACD<0 AND MACD<REF(MACD,1);
STICKLINE(吸,0,MACD,1,0),COLORRED;
STICKLINE(拉,0,MACD,1,0),COLORRED;
STICKLINE(派,0,MACD,1,0),COLORGREEN;
STICKLINE(落,0,MACD,1,0),COLORWHITE;
主力买:IF(DIF>REF(DIF,1),DIF,0),COLORRED,LINETHICK0;
主力卖:IF(DIF<REF(DIF,1),DIF,0),COLOR00FF00,LINETHICK0;
 
主力吸筹:吸,COLORYELLOW,LINETHICK0;
主力拉升:拉,COLORRED,LINETHICK0;
主力派送:派,COLORGREEN,LINETHICK0;
主力砸盘:落,COLORWHITE,LINETHICK0;
低位金叉:CROSS(DIF,DEA) AND DIF<-0.1,LINETHICK0;
STICKLINE(低位金叉,0,0.08,6,0),COLORFF00FF;
DRAWTEXT(低位金叉,0.16,'低位金叉'),COLORWHITE;
JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
二次金叉:CROSS(DIF,DEA) AND DEA<0,COLORRED,LINETHICK0;
STICKLINE(二次金叉,0,0.06,6,0),COLORFFCC00;
DRAWICON(二次金叉,DEA*0.9,7);
 
DRAWTEXT(二次金叉,0.2,'二次金叉'),COLORYELLOW;
A2:=BARSLAST(REF(CROSS(DIF,DEA),1));
A3:=BARSLAST(REF(CROSS(DEA,DIF),1));
 
底背离:REF(CLOSE,A2+1)>CLOSE AND DIF>REF(DIF,A2+1) AND CROSS(DIF,DEA),LINETHICK0;
 
STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;
 
DRAWTEXT(底背离,0.12,'底背离'),COLORFF00FF;
顶背离:=REF(CLOSE,A3+1)<CLOSE AND REF(DIF,A3+1)>DIF AND CROSS(DEA,DIF);
DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,0.25,'三全项'),COLOR0000FF,LINETHICK2;
双金叉:低位金叉 AND 二次金叉,COLORYELLOW,LINETHICK0;
三全项:低位金叉 AND 二次金叉 AND 底背离,COLORGREEN,LINETHICK0;




分时背离(顶尖财经:股票学院 ):

VAR1:=MA(LOW,1);
VAR2:=MA(HIGH,2);
VAR3:=MA(CLOSE,2);
VAR4:=(VAR3-LLV(VAR1,9))/(HHV(VAR2,9)-LLV(VAR1,9))*100;
VAR5:=SMA(VAR4,3,1);
Y:SMA(VAR5,3,1),colorred;
VAR6:=(HHV(VAR2,9)-VAR3)/(HHV(VAR2,9)-LLV(VAR1,9))*100;
VAR7:=REF(VAR3,1);
VAR8:=SMA(MAX(VAR3-VAR7,0),13,1)/SMA(ABS(VAR3-VAR7),13,1)*100;
VARB:=MA(CLOSE,3)*100/MA(CLOSE,10)-100;
VARC:=MA(CLOSE,3)*100/MA(CLOSE,10)-100;
VARD:=CLOSE*100/MA(CLOSE,10)-100;
VARE:=IF(VARB>10,10,VARB);
VARF:=IF(VARE<-10,-10,VARE);
VAR10:=IF(VARC>10,10,VARC);
VAR11:=IF(VAR10<-10,-10,VAR10);
VAR12:=REF(VARB,1);
VAR13:=100*(VAR3-REF(VAR3,1))/REF(VAR3,1);
VAR15:=REF(CLOSE,1);
VAR16:=100*(CLOSE-VAR15)/CLOSE;
VAR17:=MA(VAR13,3);
VAR18:=MA(VAR16,3);
VAR19:=(3*CLOSE+VAR1+OPEN+HIGH)/6;
VAR1A:=(20*VAR19+19*REF(VAR19,1)+18*REF(VAR19,2)+17*REF(VAR19,3)+16*REF(VAR19,4)+15*REF (VAR19,5)+14*REF(VAR19,6)+13*REF(VAR19,7)+12*REF(VAR19,8)+11*REF(VAR19,9)+10*REF(VAR19,10) +9*REF(VAR19,11)+8*REF(VAR19,12)+7*REF(VAR19,13)+6*REF(VAR19,14)+5*REF(VAR19,15)+4*REF (VAR19,16)+3*REF(VAR19,17)+2*REF(VAR19,18)+REF(VAR19,20))/210;
VAR1B:=MA(VAR1A,12);
VAR1C:=EMA(VAR1A,5);
VAR1D:=ABS(VAR1A-VAR1B);
VAR1E:=REF(VAR3,1)*0.015;
VAR1F:=REF(CLOSE,1);
VAR26:=MA(CLOSE,26);
VAR27:=VAR26+2*STD(VAR3,26);
VAR28:=VAR26-2*STD(VAR3,26);
VAR29:=VAR26+2*STD(REF(VAR3,1),26);
VAR2A:=VAR26-2*STD(REF(VAR3,1),26);
D1:=EMA(3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),5);
D2:=REF(D1,1);
STICKLINE(D1>=REF(D1,1),D1,D2,3,0),colorred;
STICKLINE(D1<REF(D1,1),D1,D2,3,0),colorgreen;
A:20,colorcyan;
B:80,coloryellow;
 

郑重声明:本文版权归原作者所有,转载文章仅为传播更多信息之目的,如作者信息标记有误,请第一时间联系我们修改或删除,多谢。