http://www.gpydt.cn

您的位置:股票易点通 > 股票公式 > 大智慧公式 > 正文

【股票入门与技巧】大智慧江恩时空,波浪理论,二指禅公式指标

江恩时空 源码:

 {江恩时空 ---主图  限期:无}

a1:=2*2*2*2*5*5*5*5*10*10+2*2*2*2*5*5*5*5*10+2*2*5*5*10+2*2*5*5+10+5;
a2:=2*2*2*2*5*5*5*5*10*10+2*2*2*2*5*5*5*5*10+2*2*5*5*10+2*2*5*5+10+5+2;
a3:=2*2*2*2*5*5*5*5*10*10+2*2*2*2*5*5*5*5*10+2*2*5*5*10+2*2*5*5+10+5+2+2;
a4:=if(date<a1,1,0);
a5:=if(date<a2,1,0);
a6:=if(date<a3,1,0);
a7:=1;{a4*a5*a6;}
a8:=(2*2*2*2*2-5*5-10+2+2+2*2*2*2*2-5*5-10+2+2+2*2*2*2*2-5*5-10+2+2)/(5-2);
a9:=1;
a10:=barslast(dispstatus=1)+1;
a11:=dispstatus=2;
a12:=if(a7=a8,hhv(h,a10),0);
a13:=llv(l,a10);
a14:=if(a7=a8,a12-a13,0);
a15:=hhvbars(h,a10);
a16:=llvbars(l,a10);
a17:=if(a7=a8,a15-a16,0);
a18:=a12-a14*0.5;
 if (a9 = 1 ) Then 
begin
a19:=if(a7=a8,(a12-a13)*0.191,0);
a20:=(a12-a13)*0.382;
a21:=if(a7=a8,(a12-a13)*0.618,0);
a22:=(a12-a13)*0.809;
 if (a17 < 0 ) Then 
begin
a23:=if(a7=a8,a12-a19,0);
a24:=a12-a20;
a25:=if(a7=a8,a12-a21,0);
a26:=a12-a22;
end
else      
begin
a23:=a13+a19;
a24:=if(a7=a8,a13+a20,0);
a25:=a13+a21;
a26:=if(a7=a8,a13+a22,0);
end;
 if (a9 = 1 ) Then 
begin
a27:=(a12-a13)*0.125;
a28:=(a12-a13)*0.25;
a29:=if(a7=a8,(a12-a13)*0.375,0);
a30:=(a12-a13)*0.625;
a31:=if(a7=a8,(a12-a13)*0.75,0);
a32:=(a12-a13)*0.875;
 if (a17 < 0 ) Then 
begin
a33:=a12-a27;
a34:=a12-a28;
a35:=a12-a29;
a36:=a12-a30;
a37:=a12-a31;
a38:=a12-a32;
end
else      
begin
a33:=a13+a27;
a34:=a13+a28;
a35:=a13+a29;
a36:=a13+a30;
a37:=a13+a31;
a38:=a13+a32;
end;
end;
end;
drawtext(a11 and (a9<>3),a12*a7,'  最高价:'+a12),align2,coloryellow;
drawtext(a11 and (a9<>3),a13*a7,'  最低价:'+a13),valign2,align2,coloryellow;
drawtext(a11 and (a9<>3),a18*a7,'  中间价:'+a18),align2,coloryellow;
drawtext(a11 and (a9=1),if(a7=a8,a33,0),'  1/8:'+numtostrn(a33,2)),align2,coloryellow;
drawtext(a11 and (a9=1),a34*a7,'  1/4:'+numtostrn(a34,2)),align2,coloryellow;
drawtext(a11 and (a9=1),a35*a7,' 3/8:'+numtostrn(a35,2)),align2,coloryellow;
drawtext(a11 and (a9=1),if(a7=a8,a36,0),' 5/8:'+numtostrn(a36,2)),align2,coloryellow;
drawtext(a11 and (a9=1),a37*a7,'  3/4:'+numtostrn(a37,2)),align2,coloryellow;
drawtext(a11 and (a9=1),if(a7=a8,a38,0),'  7/8:'+numtostrn(a38,2)),align2,coloryellow;
drawtext(a11 and (a9<>3),a12*a7,'﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉'),align2,colorff99cc;
drawtext(a11 and (a9<>3),if(a7=a8,a13,0),'﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉'),align2,colorff99cc;
drawtext(a11 and (a9<>3),if(a7=a8,a18,0),'﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉'),align2,colorff99cc;
drawtext(a11 and (a9<>3),a33*a7,'﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉'),align2,colorff99cc;
drawtext(a11 and (a9<>3),a34*a7,'﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉'),align2,colorff99cc;
drawtext(a11 and (a9<>3),a35*a7,'﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉'),align2,colorff99cc;
drawtext(a11 and (a9<>3),a36*a7,'﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉'),align2,colorff99cc;
drawtext(a11 and (a9<>3),a37*a7,'﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉'),align2,colorff99cc;
drawtext(a11 and (a9<>3),a38*a7,'﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉'),align2,colorff99cc;
a1:=2*2*2*2*5*5*5*5*10*10+2*2*2*2*5*5*5*5*10+2*2*5*5*10+2*2*5*5+10+5;
a2:=2*2*2*2*5*5*5*5*10*10+2*2*2*2*5*5*5*5*10+2*2*5*5*10+2*2*5*5+10+5+2;
a3:=2*2*2*2*5*5*5*5*10*10+2*2*2*2*5*5*5*5*10+2*2*5*5*10+2*2*5*5+10+5+2+2;
a4:=if(date<a1,1,0);
a5:=if(date<a2,1,0);
a6:=if(date<a3,1,0);
a39:=1;{a4*a5*a6;}
a40:=0+((5-2)*2)+((5-2)*2)+2-((5-2)*2-2);
a41:=((5-2)*2)*((5-2)*2-2)-((5-2)*2)-2-(((5-2)*2+((5-2)*2))/((5-2)*2+2-((5-2)*2)))+0;
a8:=(2*2*2*2*2-5*5-10+2+2+2*2*2*2*2-5*5-10+2+2+2*2*2*2*2-5*5-10+2+2)/(5-2);
a42:=hhvall(hhv(barpos,count(c,0)));
a43:=ref(h,3)=(hhv(h,2*3+1));
a44:=filter(a43,3);
a45:=backset(a44,3+1);
a46:=filter(a45,3);
a47:=ref(l,3)=(llv(l,2*3+1));
a48:=filter(a47,3);
a49:=backset(a48,3+1);
a50:=filter(a49,3);
a51:=(ref(llv(l,2*3),1)+ref(hhv(h,2*3),1))/2;
a52:=(h+l)/2;
a53:=a46 and (not(a50 and (a51>=a52))) or (barpos=a42) or (barscount(c)=1);
a54:=a50 and (not(a46 and (a51<a52)));
a55:=ref(barslast(a53),1)+1;
a56:=backset(a53 and (count(a54,a55)>0),llvbars(if(a54,l,10000),a55));
a57:=a56>ref(a56,1);
a58:=backset(a57,2);
a59:=a58>ref(a58,1);
a60:=a59 or (barpos=a42) or (barscount(c)=1);
a61:=ref(barslast(a60),1)+1;
a62:=backset(a60 and (count(a46 and (not(a50 and (a51>=a52))),a61)>0),hhvbars(if(a46 and (not(a50 and (a51>=a52))),h,0),a61));
a63:=a62>ref(a62,1);
a64:=backset(a63,2);
a65:=a64>ref(a64,1);
a66:=barslast(a65);
a67:=barslast(a59);
a68:=numtostr(a66);
a69:=numtostr(a67);
a70:=numtostr(min(a66,a67));
 if (a39=a8 and (a40=a41) ) Then 
begin
drawtext(a59,l*0.995,a68),linethick2,colorgreen;
drawtext(a65,h*1.005,a69),linethick2,colorred;
drawtext(a59,l*0.995,'  天'),linethick2,colorgreen;
drawtext(a65,h*1.005,'  天'),linethick2,colorred;
drawtext(barstatus=2,l*0.995,a70),linethick2,colorcyan;
drawtext(barstatus=2,l*0.995,'  天'),linethick2,colorcyan;
vertline(a59,2),pointdot,linethick2,colorgreen;
vertline(a65,2),pointdot,linethick2,colorred;
end
else     
begin
 if (a39 <> a8 ) Then 
begin
drawtextrel(400,710,'指标已过期'),linethick7,colorgreen;
drawtextrel(310,565,'http://www.58188.com'),linethick7,colorred;
end;
end;

{公式组: 三大主流理论指标

描述: 菲波纳奇(有未来)

注释:空

参数精灵:空 
}
{*********};





波浪理论 源码:

 {波浪理论 ---主图  限期:无}

a1:=2*2*2*2*5*5*5*5*10*10+2*2*2*2*5*5*5*5*10+2*2*5*5*10+2*2*5*5+10+5;
a2:=2*2*2*2*5*5*5*5*10*10+2*2*2*2*5*5*5*5*10+2*2*5*5*10+2*2*5*5+10+5+2;
a3:=2*2*2*2*5*5*5*5*10*10+2*2*2*2*5*5*5*5*10+2*2*5*5*10+2*2*5*5+10+5+2+2;
a4:=if(date<a1,1,0);
a5:=if(date<a2,1,0);
a6:=if(date<a3,1,0);
a7:=1;{a4*a5*a6;}
a8:=(2*2*2*2*2-5*5-10+2+2+2*2*2*2*2-5*5-10+2+2+2*2*2*2*2-5*5-10+2+2)/(5-2);
a9:=1;
a10:=barslast(dispstatus=1)+1;
a11:=dispstatus=2;
a12:=hhv(h,a10)*a7;
a13:=llv(l,a10)*a7;
a14:=if(a7=a8,a12-a13,0);
a15:=hhvbars(h,a10)*a7;
a16:=llvbars(l,a10)*a7;
a17:=if(a7=a8,a15-a16,0);
a18:=if(a7=a8,a12-a14*0.5,0);
 if (a9 = 1 ) Then 
begin
a19:=(a12-a13)*0.191;
a20:=(a12-a13)*0.382;
a21:=(a12-a13)*0.618;
a22:=(a12-a13)*0.809;
 if (a17 < 0 ) Then 
begin
a23:=a12-a19;
a24:=a12-a20;
a25:=a12-a21;
a26:=a12-a22;
end
else      
begin
a23:=a13+a19;
a24:=a13+a20;
a25:=a13+a21;
a26:=a13+a22;
end;
 if (a9 = 1 ) Then 
begin
a27:=(a12-a13)*0.125;
a28:=(a12-a13)*0.25;
a29:=(a12-a13)*0.375;
a30:=(a12-a13)*0.625;
a31:=(a12-a13)*0.75;
a32:=(a12-a13)*0.875;
 if (a17 < 0 ) Then 
begin
a33:=a12-a27;
a34:=a12-a28;
a35:=a12-a29;
a36:=a12-a30;
a37:=a12-a31;
a38:=a12-a32;
end
else      
begin
a33:=a13+a27;
a34:=a13+a28;
a35:=a13+a29;
a36:=a13+a30;
a37:=a13+a31;
a38:=a13+a32;
end;
end;
end;
drawtext(a11 and (a9<>3),if(a7=a8,a12*a7,0),'  最高价:'+a12),align2,colorgreen;
drawtext(a11 and (a9<>3),a13*a7,'  最低价:'+a13),valign2,align2,colorgreen;
drawtext(a11 and (a9<>3),if(a7=a8,a18*a7,0),'  50%:'+a18),align2,coloryellow;
drawtext(a11 and (a9=1),a23*a7,'  0.191:'+numtostrn(a23,2)),align2,coloryellow;
drawtext(a11 and (a9=1),if(a7=a8,a24*a7,0),'  0.382:'+numtostrn(a24,2)),align2,coloryellow;
drawtext(a11 and (a9=1),if(a7=a8,a25*a7,0),'  0.618:'+numtostrn(a25,2)),align2,coloryellow;
drawtext(a11 and (a9=1),a26*a7,'  0.809:'+numtostrn(a26,2)),align2,coloryellow;
drawtext(a11 and (a9=1),if(a7=a8,a33*a7,0),'  1/8:'+numtostrn(a33,2)),align2,colorgreen;
drawtext(a11 and (a9=1),a34*a7,'  1/4:'+numtostrn(a34,2)),align2,colorgreen;
drawtext(a11 and (a9=1),a35*a7,' 3/8:'+numtostrn(a35,2)),colorgreen;
drawtext(a11 and (a9=1),if(a7=a8,a36*a7,0),' 5/8:'+numtostrn(a36,2)),colorgreen;
drawtext(a11 and (a9=1),a37*a7,'  3/4:'+numtostrn(a37,2)),align2,colorgreen;
drawtext(a11 and (a9=1),a38*a7,'  7/8:'+numtostrn(a38,2)),align2,colorgreen;
drawtext(a11 and (a9<>3),a12*a7,' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),linethick7,align2,colorred;
drawtext(a11 and (a9<>3),a13*a7,' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),linethick7,align2,colorred;
drawtext(a11 and (a9<>3),a18*a7,' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),linethick7,align2,colorff0000;
drawtext(a11 and (a9=1),a23*a7,'﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ '),linethick0,align2,color208fff;
drawtext(a11 and (a9=1),if(a7=a8,a24*a7,0),'﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ '),linethick0,align2,color208fff;
drawtext(a11 and (a9=1),a25*a7,'﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ '),linethick0,align2,color208fff;
drawtext(a11 and (a9=1),a26*a7,'﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ '),linethick0,align2,color208fff;
drawtext(a11 and (a9=1),a33*a7,'                                                                                                ﹉﹉﹉﹉'),align2,colorgreen;
drawtext(a11 and (a9=1),a34*a7,'                                                                                                ﹉﹉﹉﹉'),align2,colorgreen;
drawtext(a11 and (a9=1),a35*a7,'﹉﹉'),colorgreen;
drawtext(a11 and (a9=1),if(a7=a8,a36*a7,0),'﹉﹉'),colorgreen;
drawtext(a11 and (a9=1),a37*a7,'                                                                                                ﹉﹉﹉﹉'),align2,colorgreen;
drawtext(a11 and (a9=1),a38*a7,'                                                                                                ﹉﹉﹉﹉'),align2,colorgreen;
a1:=2*2*2*2*5*5*5*5*10*10+2*2*2*2*5*5*5*5*10+2*2*5*5*10+2*2*5*5+10+5;
a2:=2*2*2*2*5*5*5*5*10*10+2*2*2*2*5*5*5*5*10+2*2*5*5*10+2*2*5*5+10+5+2;
a3:=2*2*2*2*5*5*5*5*10*10+2*2*2*2*5*5*5*5*10+2*2*5*5*10+2*2*5*5+10+5+2+2;
a4:=if(date<a1,1,0);
a5:=if(date<a2,1,0);
a6:=if(date<a3,1,0);
a39:=1;{a4*a5*a6;}
a40:=0+((5-2)*2)+((5-2)*2)+2-((5-2)*2-2);
a41:=((5-2)*2)*((5-2)*2-2)-((5-2)*2)-2-(((5-2)*2+((5-2)*2))/((5-2)*2+2-((5-2)*2)))+0;
a8:=(2*2*2*2*2-5*5-10+2+2+2*2*2*2*2-5*5-10+2+2+2*2*2*2*2-5*5-10+2+2)/(5-2);
a42:=hhvall(hhv(barpos,count(c,0)));
a43:=ref(h,3)=(hhv(h,2*3+1));
a44:=filter(a43,3);
a45:=backset(a44,3+1);
a46:=filter(a45,3);
a47:=ref(l,3)=(llv(l,2*3+1));
a48:=filter(a47,3);
a49:=backset(a48,3+1);
a50:=filter(a49,3);
a51:=(ref(llv(l,2*3),1)+ref(hhv(h,2*3),1))/2;
a52:=(h+l)/2;
a53:=a46 and (not(a50 and (a51>=a52))) or (barpos=a42) or (barscount(c)=1);
a54:=a50 and (not(a46 and (a51<a52)));
a55:=ref(barslast(a53),1)+1;
a56:=backset(a53 and (count(a54,a55)>0),llvbars(if(a54,l,10000),a55));
a57:=a56>ref(a56,1);
a58:=backset(a57,2);
a59:=a58>ref(a58,1);
a60:=a59 or (barpos=a42) or (barscount(c)=1);
a61:=ref(barslast(a60),1)+1;
a62:=backset(a60 and (count(a46 and (not(a50 and (a51>=a52))),a61)>0),hhvbars(if(a46 and (not(a50 and (a51>=a52))),h,0),a61));
a63:=a62>ref(a62,1);
a64:=backset(a63,2);
a65:=a64>ref(a64,1);
a66:=zig(3,5);
a67:=a66>ref(a66,1) and (ref(a66,1)<=ref(a66,2)) and (ref(a66,2)<=ref(a66,3));
a68:=a66<ref(a66,1) and (ref(a66,1)>=ref(a66,2)) and (ref(a66,2)>=ref(a66,3));
a69:=zig(3,13);
a70:=zig(3,10)>ref(zig(3,10),1) and (ref(zig(3,10),1)<=ref(zig(3,10),2)) and (ref(zig(3,10),2)<=ref(zig(3,10),3));
a71:=zig(3,10)<ref(zig(3,10),1) and (ref(zig(3,10),1)>=ref(zig(3,10),2)) and (ref(zig(3,10),2)>=ref(zig(3,10),3));
a72:=zig(3,26);
a73:=zig(3,20)>ref(zig(3,20),1) and (ref(zig(3,20),1)<=ref(zig(3,20),2)) and (ref(zig(3,20),2)<=ref(zig(3,20),3));
a74:=zig(3,20)<ref(zig(3,20),1) and (ref(zig(3,20),1)>=ref(zig(3,20),2)) and (ref(zig(3,20),2)>=ref(zig(3,20),3));
a75:=zig(3,55);
a76:=barslast(a66<ref(a66,1));
a77:=barslast(a66>ref(a66,1));
a78:=barslast(a69<ref(a69,1));
a79:=barslast(a69>ref(a69,1));
a80:=barslast(a72<ref(a72,1));
a81:=barslast(a72>ref(a72,1));
a82:=if(a69>ref(a69,1),count(a67,a78),0);
a83:=if(a69>ref(a69,1),count(a68,a78),0);
a84:=if(a69<ref(a69,1),count(a67,a79),0);
a85:=if(a69<ref(a69,1),count(a68,a79),0);
a86:=if(a72>ref(a72,1),count(a70,a80),0);
a87:=if(a72>ref(a72,1),count(a71,a80),0);
a88:=if(a72<ref(a72,1),count(a70,a81),0);
a89:=if(a72<ref(a72,1),count(a71,a81),0);
a90:=hhv(h,120);
a91:=filter(backset(filter(ref(h,10)=(hhv(h,2*10+1)),10),10+1),10);
a92:=filter(backset(filter(ref(l,10)=(llv(l,2*10+1)),10),10+1),10);
a93:=ref(l,barslast(a92));
a94:=barslast(a91)<barslast(a92) and not(a91);
a95:=barslast(a91)>barslast(a92) and not(a92);
 if (a39=a8 and (a40=a41) ) Then 
begin
drawline(a59,l,a65,h,0),pointdot,linethick1,colorWhite;
drawline(a65,h,a59,l,0),pointdot,linethick1,colorWhite;
drawtext(a67 and (a84=1),l*0.97,'(Ⅰ)'),colorcyan;
drawtext(a68 and (a85=2),h*1.03,'(Ⅱ)'),colorcyan;
drawtext(a70 and (a82=1),l*0.97,'(Ⅲ)'),colorcyan;
drawtext(a68 and (a69>ref(a69,1)) and (a83=1),h*1.02,'⑴'),colorred;
drawtext(a67 and (a69>ref(a69,1)) and (a82=2),l*0.98,'⑵'),colorred;
drawtext(a68 and (a69>ref(a69,1)) and (a82=2),h*1.02,'⑶'),colorred;
drawtext(a67 and (a69>ref(a69,1)) and (a82=3),l*0.98,'⑷'),colorred;
drawtext(a71 and (a72>ref(a72,1)) and (a87=1),h*1.02,'⑸'),colorred;
drawtext(a70 and (a88=1),l*0.94,'【A】'),colorgreen;
drawtext(a71 and (a89=2),h*1.05,'【B】'),colorgreen;
drawtext(a73 and (a86=1),l*0.94,'【C】'),colorgreen;
drawtext(a71 and (a72>ref(a72,1)) and (a87=1),h*1.04,'①'),linethick3,coloryellow;
drawtext(a70 and (a72>ref(a72,1)) and (a86=2),l*0.96,'②'),linethick3,coloryellow;
drawtext(a71 and (a72>ref(a72,1)) and (a87=2) or (a87=0 or (a87=2) and a71),h*1.04,'③'),linethick3,coloryellow;
drawtext(a70 and (a72>ref(a72,1)) and (a86=3),l*0.96,'④'),linethick3,coloryellow;
a11:=ref(h,barslast(a91));
end
else     
begin
 if (a39 <> a8 ) Then 
begin
drawtextrel(400,710,'指标已过期'),linethick7,colorgreen;
drawtextrel(310,565,'http://data520.taobao.com'),linethick7,colorred;
end;
end;

{公式组: 三大主流理论指标

描述: 黄金分割(有未来)

注释:空

参数精灵:空 

顶尖财经:股票学院

}
{*********};




二指禅公式:

趋势1:(EMA(CLOSE,7)) - (EMA(CLOSE,21)),colorYellow;
趋势2:EMA(趋势1,7),COLORSTICK,colorRed;
a1:=(CLOSE / (REF((LLV(LOW,35)),5))) < 1;
决策:IF(a1,0.5,0),STICK,ColorFF0000;
阳指必买:IF((((TROUGHBARS(3,15,1)) = 0) AND (HIGH > (LOW + 0.01))),1,-1),linethick2,colorRed;
阴指必卖:IF(((PEAKBARS(3,15,1)) = 1),1,2),linethick2,colorGreen;
趋势线:((EMA(WINNER(CLOSE),7)) - (EMA(WINNER(CLOSE),35))) * 5,colorRed;
顶部区域线:EMA((CLOSE / (REF((HHV(CLOSE,7)),50))),1),linethick1,Color007000;
 

郑重声明:本文版权归原作者所有,转载文章仅为传播更多信息之目的,如作者信息标记有误,请第一时间联系我们修改或删除,多谢。