http://www.gpydt.cn

您的位置:股票易点通 > 股票公式 > 大智慧公式 > 正文

【股票投资】大智慧选姊妹花,W-MACD指标

选姊妹花:

Var0:=1;
Var2:=1;
Var3:=ZIG(2, P)>REF(ZIG(2, P), 1) AND REF(ZIG(2, P), 1)<REF(ZIG(2, P), 2)*Var2;
Var4:=ZIG(1, P)<REF(ZIG(1, P), 1) AND REF(ZIG(1, P), 1)>REF(ZIG(1, P), 2)*Var2;
Var5:=ZIG(2, 18)>REF(ZIG(2, 18), 1) AND REF(ZIG(2, 18), 1)<REF(ZIG(2, 18), 2)*Var2;
Var6:=ZIG(1, 18)<REF(ZIG(1, 18), 1) AND REF(ZIG(1, 18), 1)>REF(ZIG(1, 18), 2)*Var2;
Var7:=ZIG(2, 28)>REF(ZIG(2, 28), 1) AND REF(ZIG(2, 28), 1)<REF(ZIG(2, 28), 2)*Var2;
Var8:=ZIG(1, 28)<REF(ZIG(1, 28), 1) AND REF(ZIG(1, 28), 1)>REF(ZIG(1, 28), 2)*Var2;
Var9:=Var3*Var2;
Var10:=Var4*Var2;
姊妹花:Var3*Var2,linestick,   LINETHICK5, COLOR00aaff;
多头笑:Var4*Var2,linestick , LINETHICK5, COLORcyan;
DRAWICON(Var9, Var9, 3)*Var2;
DRAWICON(Var10, Var10, 1)*Var2;
Var1:=ZIG(3,34);
与庄共舞!: REF(Var1,2)>REF(Var1,1) AND Var1>REF(Var1,1),stick , colorred ,linethick7;
乌云盖顶:ref(var1,2)<ref(var1,1) and var1<ref(var1,1),stick  ,COLORff22cc, linethick5;
DRAWICON(与庄共舞!=1,1.1,3);
DRAWICON(乌云盖顶=1,1.1,1),colorgreen;
DRAWTEXT(  与庄共舞!=1,0.4  ,'猎豹出击!' ),colorgreen;
DRAWTEXT( 乌云盖顶=1,0.7  ,'乌云盖顶及时离场休息!' ),coloryellow, linethick3;



W-MACD(顶尖财经:股票学院 ):
 
发个MACD计算本周期金死叉值的指标公式。默认周期的(26,12,9),非默认值需另算。大智慧的,“今值”就是本周期DIFF交叉DEM的计算值。开盘就能知道今天的金(死)叉值是多少。
 
EMA9:=EMA(C,9);
EMA12:=EMA(C,12);
EMA26:=EMA(C,26);
今值:(13872/13*11*REF(EMA12,1)-11424/10*8*REF(EMA9,1)-2448/27*25*REF(EMA26,1))/(11424/10*2-13872/13*2+2448/27*2);
 

郑重声明:本文版权归原作者所有,转载文章仅为传播更多信息之目的,如作者信息标记有误,请第一时间联系我们修改或删除,多谢。