http://www.gpydt.cn

您的位置:股票易点通 > 股票公式 > 大智慧公式 > 正文

【股票知识干货】大智慧得分手抄底-金钻公式,龙回头,骑黑马稳健版指标

得分手抄底---金钻公式(大智慧公式,副图,源码,测试图)

{得分手抄底---金钻公式}

A1:=REF(CLOSE,1);

A2:=((SMA((MAX((CLOSE - A1),0)),5,1)) / (SMA(ABS((CLOSE - A1)),5,1))) * 100;

A3:=SUM((MAX((MAX((HIGH - LOW),ABS((HIGH - A1)))),ABS((LOW - A1)))),10);

A4:=HIGH - (REF(HIGH,1));

A5:=(REF(LOW,1)) - LOW;

A6:=SUM((IF(((A4 > 0) AND (A4 > A5)),A4,0)),10);

A7:=SUM((IF(((A5 > 0) AND (A5 > A4)),A5,0)),10);

A8:=(A6 * 100) / A3;

A9:=(A7 * 100) / A3;

A10:=MA(((ABS((A9 - A8)) / (A9 + A8)) * 100),5);

A11:=A2 + A10;

A12:=((A10 + (REF(A10,5))) / 2) + A2;

A13:=(100 * ((HHV(HIGH,10)) - CLOSE)) / ((HHV(HIGH,10)) - (LLV(LOW,10)));

A14:=A2 - A13;

A15:=A11 + A14;

YXF:=LLV(A15,1);

金鱼:=CROSS(YXF,0);

DIFF:=(EMA(CLOSE,12)-EMA(CLOSE,26))*100/EMA(CLOSE,26);

DEA:=EMA(DIFF,9); 

MACD:=2*(DIFF-DEA);

预警:=MACD<0 AND MACD>REF(MACD,1);

VAR2:=LLV(LOW,10);

VAR3:=HHV(HIGH,25);

动力线:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4);

A:=动力线>REF(动力线,1); 

红柱:=CROSS(A,0.5);

TJZB1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));

随机:=CROSS(TJZB1,10); 

CSS:=((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100);

ST:=CROSS(20,EMA(CSS,3)); 

AA:=REF(CLOSE,1);

BBB:=SMA(MAX(CLOSE-AA,0),5,1)/SMA(ABS(CLOSE-AA),5,1)*1000;

HHH:=BBB-LLV(BBB,10);

SS:=(MA(HHH,2)*3+HHH*13)/16;

短线买点:=IF(SS>13,MA(SS,2),SS)/6;

短线出击:=IF(CROSS(短线买点,1) AND (短线买点<30),30,1);

XG:金鱼 AND 红柱 AND 预警 AND 随机 AND 短线出击=30,COLOR00FF00;





龙回头:

 {龙回头--主图指标}

 
MA1:MA(CLOSE,5);
MA2:MA(CLOSE,10);
MA3:MA(CLOSE,20);
MA4:MA(CLOSE,30);
MA5:MA(CLOSE,60);
强势线:MA(C,25)+MA(C,25)*20/100,LINETHICK2,COLORRED;
DM1:=C/REF(C,1)>1.09 AND C>=O;
DM2:=REF(C,4)<0.96 AND REF(C,2)/REF(C,3)<1.02 AND REF(C,1)/REF(C,2)<1.02;
DM3:=MAX(REF(C,1),REF(O,1))/MIN(REF(C,1),REF(O,1))<1.036 AND MAX(REF(C,2),REF(O,2))/MIN(REF(C,2),REF(O,2))<1.036
AND MAX(REF(C,3),REF(O,3))/MIN(REF(C,3),REF(O,3))<1.036;
DXGM:=COUNT(REF(DM1,1),10) AND DM2 AND DM3;
AM1:=C/REF(C,1)>1.09 AND C>=O;
AM2:=REF(C,3)<0.96 AND REF(C,2)/REF(C,3)<1.02 AND REF(C,1)/REF(C,2)<1.02;
AM3:=MAX(REF(C,1),REF(O,1))/MIN(REF(C,1),REF(O,1))<1.036 AND MAX(REF(C,2),REF(O,2))/MIN(REF(C,2),REF(O,2))<1.036;
AXGM:=COUNT(REF(AM1,1),10) AND AM2 AND AM3;
BM1:=C/REF(C,1)>1.09 AND C>=O;
BM2:=REF(C,2)<0.96;
BM3:=MAX(REF(C,1),REF(O,1))/MIN(REF(C,1),REF(O,1))<1.05;
BXGM:=COUNT(REF(BM1,1),10) AND BM2 AND BM3;
CM1:=C/REF(C,1)>1.09 AND C>=O;
CM2:=REF(C,1)<0.96;
CXGM:=COUNT(REF(CM1,1),10) AND CM2;
SGX:=MA(C,25)+MA(C,25)*20/100;
GYTJ1:=(BETWEEN(O/MA(C,10),1.02,0.99) OR BETWEEN(L/MA(C,10),1.04,0.99) OR (BETWEEN(L/SGX,1.01,0.995) AND SGX/MA(C,10)<1.08))AND C>MA(C,10)
AND BETWEEN(C/REF(C,1),1.05,0.97) AND MA(C,5)>MA(C,10) AND MA(C,5)/MA(C,10)>1.01 AND H/MAX(C,O)<1.04
AND C>MA(C,120)AND MA(C,20)>MA(C,60) AND MA(C,20)>MA(C,120) AND REF(L,1)/REF(MA(C,10),1)>0.998; 
GYTJ2:=REF(C,1)>MA(C,20) AND MA(C,20)>MA(C,30);
ABXG:=(DXGM OR AXGM OR BXGM OR CXGM) AND GYTJ1 AND GYTJ2;
DRAWICON(ABXG,L*0.98,11);
DRAWTEXT(ABXG,L*0.94,'龙回头'),COLORWHITE;
SCMXG:=COUNT(ABXG,5) AND CROSS(MA(C,10),MA(C,5));
DRAWICON(SCMXG,L*0.98,9);
DRAWTEXT(SCMXG,L*0.94,'二次尾买'),COLORYELLOW;



骑黑马稳健版 主图指标和选股选股:

{骑黑马稳健版---大智慧版本}

N:=13;

M:=90;

MA111:=MA(CLOSE,20);

MA112:=MA(CLOSE,40);

MA113:=MA(CLOSE,60);

MA13:=MA(C,13);

MA34:=MA(C,34);

MA55:=MA(C,55);

角度MA13:=ATAN((MA13/REF(MA13,1)-1)*100)*180/3.1416;

角度MA34:=ATAN((MA34/REF(MA34,1)-1)*100)*180/3.1416;

角度MA55:=ATAN((MA55/REF(MA55,1)-1)*100)*180/3.1416;

A11:=OPEN<MA111 OR OPEN<MA112 OR OPEN<MA113;

A12:=C>MAX(MA111,MAX(MA112,MA113));

{顶尖财经:股票学院 }

A13:=V/MA(V,30)>1.2;

A14:=C/REF(C,1)>1.049;

生命:=EXPMA(EXPMA(CLOSE,50),1);

半:=MA(CLOSE,125);

年:=MA(CLOSE,240);

涨幅:=(C-REF(C,1))/REF(C,1)*100;

换手率:=v/capital/100;

条件:=C>生命 AND 生命>半 AND 半>年 AND 涨幅>6.5 AND 换手率>6;

条件2:=HHVBARS(HIGH,43)<LLVBARS(HIGH,43) AND (HHV( HIGH,43)-LLV( LOW,43))/LLV( LOW,43)<90/100;

黑马:A11 AND A12 AND A13 AND A14 AND 条件 AND 条件2 AND C>MA13 AND C>MA34 AND MA13>MA34 AND MA34>MA55 AND 角度MA13>0 AND 角度MA34>0 AND 角度MA55>0;



删除无用的语句,改为如下:

{骑黑马稳健版选股选股}

MA111:=MA(CLOSE,20);

MA112:=MA(CLOSE,40);

MA113:=MA(CLOSE,60);

MA13:=MA(C,13);

MA34:=MA(C,34);

MA55:=MA(C,55);

角度MA13:=ATAN((MA13/REF(MA13,1)-1)*100)*180/3.1416;

角度MA34:=ATAN((MA34/REF(MA34,1)-1)*100)*180/3.1416;

角度MA55:=ATAN((MA55/REF(MA55,1)-1)*100)*180/3.1416;

A11:=OPEN<MA111 OR OPEN<MA112 OR OPEN<MA113;

A12:=C>MAX(MA111,MAX(MA112,MA113));

A13:=V/MA(V,30)>1.2;

A14:=C/REF(C,1)>1.049;

生命:=EXPMA(EXPMA(CLOSE,50),1);

半:=MA(CLOSE,125);

年:=MA(CLOSE,240);

涨幅:=(C-REF(C,1))/REF(C,1)*100;

换手率:=v/capital/100;

条件:=C>生命 AND 生命>半 AND 半>年 AND 涨幅>6.5 AND 换手率>6;

条件2:=HHVBARS(HIGH,43)<LLVBARS(HIGH,43) AND (HHV( HIGH,43)-LLV( LOW,43))/LLV( LOW,43)<90/100;

黑马:A11 AND A12 AND A13 AND A14 AND 条件 AND 条件2 AND C>MA13 AND C>MA34 AND MA13>MA34 AND MA34>MA55 AND 角度MA13>0 AND 角度MA34>0 AND 角度MA55>0;

 
 

郑重声明:本文版权归原作者所有,转载文章仅为传播更多信息之目的,如作者信息标记有误,请第一时间联系我们修改或删除,多谢。