http://www.gpydt.cn

您的位置:股票易点通 > 股票公式 > 大智慧公式 > 正文

【股票投资】大智慧源码:A公主思春

    该指标主要研究市场多空双方力量对比和行情发展趋势。正量代表多方力量,负量代表空方力量,趋势代表多空双方力量对比的结果。
    正量大于负量是股价上升的先决条件,正量大于20是股价具备上升力量的必要条件,所以当正量与负量金叉且正量大于20是中短线的买入点。反之,当正量与负量死叉且负量大于20是中短线的卖出点。
    趋势线上升且大于20表示股价上升或下降的趋势正在发展,趋势线下降表示股价上升或下降的趋势正在转变,趋势线小于20表示股价上升或下降的趋势不明。
    当趋势线大于50时正量线或负量线的顶背离或底背离对股价的顶部或底部有较好的提示作用。( 顶尖财经 股票学院: )
    该指标仅适用于在明确的趋势行情中作辅助判断,对盘整行情不适用。

 {参数N=14}

TR := SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(C,1))),ABS(LOW-REF(C,1))),N,1);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
DMP:= SMA(IF(HD>0 AND HD>LD,HD,0),N,1);
DMM:= SMA(IF(LD>0 AND LD>HD,LD,0),N,1);
PDI:=SMA(DMP*100/TR,2,1);
MDI:=SMA(DMM*100/TR,2,1);
ADX:=SMA(ABS(MDI-PDI)/(MDI+PDI)*100,6,1);
正量:PDI, COLOR9900ff;
负量:MDI,COLORcccc66;
公主:ADX,COLORFFAA66,LINETHICK2;
STICKLINE(PDI>MDI,PDI,MDI,1,0),COLOR0066ff;
STICKLINE(PDI<MDI,PDI,MDI,1,0),COLOR005500;
STICKLINE(C>0,19.8,20.2,2,0),COLORffffff;
POLYLINE(C>0,PDI), COLOR9900ff,;
POLYLINE(C>0,MDI),COLORcccc66,;
POLYLINE(C>0,ADX),COLORFFAA66,linethick2;
 

郑重声明:本文版权归原作者所有,转载文章仅为传播更多信息之目的,如作者信息标记有误,请第一时间联系我们修改或删除,多谢。